Kategórie
Novinky Pre používateľov

PHP 8 dostupné ihneď po oficiálnom vydaní. Otestujte si novú verziu

Dnes (26. novembra 2020) vychádza nová verzia PHP 8. Na rozdiel od predošlej verzie PHP 7.4 ide o major release vydanie, ktoré prináša úplné novinky aj zmeny nekompatibilné s predošlými vydaniami.

PHP 8 vo WebSupporte

PHP 8 bude na našich hostingových serveroch dostupné krátko po oficiálnom vydaní. Ak budete chcieť novú verziu ihneď otestovať, stačí sa prihlásiť do WebAdminu a zmeniť PHP verziu.


Pred aktualizáciou produkčného webu odporúčame otestovať kompatibilitu webu s novou verziou PHP. Ak si neviete rady, obráťte sa na vášho správcu webu.


WordPress a ostatné CMS

Najnovšia verzia WordPress 5.6 s podporou PHP 8 počíta. No i tak tvorcovia používajú výraz beta compatibility. A to najmä z dôvodu, že PHP 8 obsahuje množstvo zmien, ktoré nie sú kompatibilné s predošlou verziou PHP 7.x a na PHP 8 je potrebné pripraviť aj pluginy a témy – jadro WordPress nebeží prakticky nikdy izolované.

Pripravovaný Drupal 9.1 (RC1, RC3 info) obsahuje podporu PHP 8, ale podľa slov tvorcov (v popise RC1 vydania) sa o úplnej podpore bude dať hovoriť až s Drupal 9.2.

Vo všeobecnosti platí, že redakčné systémy zrerejňujú podobné informácie na stránkach dokumentácie/podpory. Preskúmajte ich.


Nové funkcie PHP 8 nie sú s PHP 7 alebo PHP 5 kompatibilné. Na weboch so staršou verziou PHP pravdepodobne spôsobia kritické chyby.


Každý rok nová verzia

Nové verzie PHP už roky vychádzajú 1x ročne, v poslednom kvartáli na prelome novembra a decembra. S príchodom novej verzie zároveň končí oficiálna podpora jednej z predošlých verzií. V prípade vydania PHP 8 to znamená:

  • úplné ukončenie podpory PHP 7.2.
  • PHP 7.3 prechádza do režimu security fixes only

Tohoto oficiálneho cyklu sa začíneme držať čoraz viac aj my vo WebSupporte. Preto popri pridávaní nových verzií odstraňujeme tie staršie a vyzývame majiteľov webu k aktualizácii. V roku 2019 sme takto odstraňovali PHP 5 (aj keď stále nie úplne), budúci rok chceme pokračovať.

Minimálna odporúčaná verzia

Z hľadiska optimálnej bezpečnosti a výkonu vášho webu odporúčame používať minimálne PHP 7.4. Túto verziu nastavujeme ako predvolenú pre všetky nové hostingy.

Oficiálna dokumentácia PHP 8

Autor: Karol Vörös

Produktový manažér hostingových produktov, translation editor slovenskej lokalizácie WordPress.

Pridaj komentár

Vaša e-mailová adresa nebude zverejnená. Vyžadované polia sú označené *