Ukončenie podpory PHP verzie 5.6

PHP je najpoužívanejší skriptovací jazyk pre web. Podľa W3Techs ho používa okolo 80 % webov. Na väčšine zdieľaných hostingov predstavuje jedinú dostupnú možnosť. Rovnako ako každý softvér, aj PHP má svoj životný cyklus. Pravidelne vychádzajú novšie verzie, ktoré pridávajú nové funkcie a opravujú chyby a nedostatky tých predošlých. Nové verzie vychádzajú približne každý rok a ich podpora trvá väčšinou 2 roky.


Dátum ukončenia podpory PHP 5.6

Oficiálna podpora pre PHP verziu 5.6 skončila v decembri 2018. Na našich serveroch ostane PHP 5.6 aktívne aj naďalej. Napriek tomu je aktualizácia na PHP 7.x odporúčaná.

Aké systémy podporujú vyššiu PHP verziu?

Ak používate moderné redakčné systémy ako WordPress, Joomla, Prestashop, …, zmena podľa našich skúseností prebehne takmer vždy hladko bez problémov. Jedinou podmienkou je pred zmenou PHP verzie aktualizovať systém, aj doplnky stránky (pluginy, témy, …).

Odporúčamá vám aktualizovať z PHP 5.6 na PHP 7.1 a novšie, keďže podpora PHP verzie 7.0 v decembri 2018 skončila tiež a apríli 2019 ju u nás vypneme. V prípade, ak by stránka nebola pripravené na prechod na vyššiu verziu a vypíše chybu, môžete stále upraviť PHP verziu späť na pôvodnú hodnotu.

V prípade, že používate aplikáciu vytvorené na mieru, odporúčame kontaktovať programátora / správcu stránky a požiadať o preverenie. Odporúčame pozrieť oficiálnu stránku pre migráciu z PHP 5.6 na vyššiu verziu.

Podporuje moja stránka novšie verzie?

Pre otestovanie funkčnosti stránky na iných PHP verziách sme vyvinuli nástroj, ktorý dokáže nasimulovať chod stránky na inej PHP verzii ako je aktuálne používaná. Pozrite si článok ohľadne testovania PHP verzie na hostingu.

Ako aktualizovať PHP verziu z 5.6 na novšiu?

PHP verziu viete zmeniť veľmi jednoducho cez Webadmin.
1. Prihláste sa prosím na stránku admin.websupport.sk
2. Prejdite do služieb
3. Kliknite v službách na doménu
4. Vľavo v menu sekcia WEB -> PHP nastavenia
5. Uložte zmenu. Zmena PHP verzie sa prejaví do 15 minút

Viac o tom, prečo by ste nemali používať staré verzie PHP sa dozviete na našom blogu.

Aktualizované 14. februára 2019

Bol pre vás tento návod nápomocný?

Mohlo by vás tiež zaujímať: